<!DOCTYPE html>
<html lang="en-US">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta charset="UTF-8" />
	<link rel="shortcut icon" href="http://www.roxwalkoff.com/wp-content/uploads/2016/03/fav-icon.png" />
	
    <!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
	<title>Is It Time to Panic Yet? Waiting for a Rockies Swoon&#8230; &#8211; Rox Walk Off: Colorado Rockies News and Fan Gathering Place</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0"><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Rox Walk Off: Colorado Rockies News and Fan Gathering Place &raquo; Feed" href="http://www.roxwalkoff.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rox Walk Off: Colorado Rockies News and Fan Gathering Place &raquo; Comments Feed" href="http://www.roxwalkoff.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rox Walk Off: Colorado Rockies News and Fan Gathering Place &raquo; Is It Time to Panic Yet? Waiting for a Rockies Swoon&#8230; Comments Feed" href="http://www.roxwalkoff.com/is-it-time-to-panic-yet-waiting-for-a-rockies-swoon/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.roxwalkoff.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bwp-rc-css'  href='http://www.roxwalkoff.com/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.roxwalkoff.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://www.roxwalkoff.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.1.6' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='sidebar-login-css'  href='http://www.roxwalkoff.com/wp-content/plugins/sidebar-login/assets/css/sidebar-login.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='style_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/style.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='custom_css_roxwall-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/custom_roxwallcss.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/prettyphoto.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/bootstrap.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/font-awesome.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://www.roxwalkoff.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://www.roxwalkoff.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='responsive_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/responsive.css?ver=4.7.5' type='text/css' media='all' />
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/jquery/jquery.js?ver=1.11.0'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/bwp-recent-comments/js/bwp-rc-ajax.js?ver=1.2.2'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.1.6'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.1.6'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/sidebar-login/assets/js/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"http:\/\/www.roxwalkoff.com\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"0","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar_login_error"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/sidebar-login/assets/js/sidebar-login.min.js?ver=2.7.3'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/functions.js?ver=4.7.5'></script>
<link rel='https://api.w.org/' href='http://www.roxwalkoff.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.roxwalkoff.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.roxwalkoff.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Regaining Sea Legs' href='http://www.roxwalkoff.com/regaining-sea-legs/' />
<meta name="generator" content="WordPress 4.7.5" />
<link rel="canonical" href="http://www.roxwalkoff.com/is-it-time-to-panic-yet-waiting-for-a-rockies-swoon/" />
<link rel='shortlink' href='http://www.roxwalkoff.com/?p=16968' />
<link rel="alternate" type="application/json+oembed" href="http://www.roxwalkoff.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.roxwalkoff.com%2Fis-it-time-to-panic-yet-waiting-for-a-rockies-swoon%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.roxwalkoff.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.roxwalkoff.com%2Fis-it-time-to-panic-yet-waiting-for-a-rockies-swoon%2F&#038;format=xml" />

<!-- BEGIN recaptcha, injected by plugin wp-recaptcha-integration  -->

<!-- END recaptcha -->
<script type="text/javascript">
	var bwp_ajax_url = 'http://www.roxwalkoff.com/';
</script>
<meta name="generator" content="Powered by Slider Revolution 5.1.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
    </head>
	<body class="post-template-default single single-post postid-16968 single-format-standard" style="background:url(http://www.roxwalkoff.com/wp-content/uploads/2016/03/rwoBack1.jpg) no-repeat  center 	fixed" style="background:#e95842 url()"  >
 				<style type="text/css">
		.pix-colr, .pix-colrhvr:hover,.price-table article:hover h3,.breadcrumbs ul li.pix-active,#footer p a:hover,.is-countdown span:before,.pagination .active,
/* New Clases Add*/.event-listing article:hover .text .pix-post-title a,.cs-post-title a,.pagination .active,.blog-medium-options li a,.is-countdown span,.widget ul li:hover a { color:#240347 !important;
		}
		.pix-bgcolr,.pix-bgcolrhvr:hover,nav.navigation > ul > li > a:before,.cart-sec span,.navigation ul ul li:hover > a,.navigation ul > li.current-menu-item > a,
		.navigation ul ul li.current-menu-item > a,.price-table article:hover .pix-price-box, .event.evevt-listing article:hover .text .btn-boobked, .match-result.match-lost p,.event.event-listing.event-listing-v2 article:hover,.cycle-pager-active,.widget .tagcloud a:hover, .event.event-listing article:hover .text .btn-boobked, .flex-direction-nav li a:hover /**/, .our-team-sec article:hover figure figcaption .pix-post-title a,.footer-widget .widget_newsletter .error,.news-section article:hover .text,.password_protected form input[type="submit"],.team-vertical article figcaption .caption h2,
#respond form input[type="submit"],#wp-calendar caption,.gallery ul li figure figcaption a,.woocommerce-pagination ul li a:hover,.woocommerce-pagination ul li span,.woocommerce-tabs .tabs .active a, span.match-category.cat-neutral, .event.event-listing article:hover .text .btn,.widget_search form input[type="submit"], .woocommerce .button,.onsale,.gallery ul li:hover .text,.footer-icons .followus a:hover,
/* New Clases Add*/.searchform button,.tabs.horizontal .nav-tabs li.active a,p.stars span a.active,.event.event-listing.event-listing-v2 .btn-viewall,.featured-title,
.pix-feature article .blog-bottom .btn,.pix-feature .featured,.blog-vertical .tab-content header.pix-heading-title h2,header #lang_sel a:hover, header #lang_sel ul ul a:hover,
.post-tags a:hover,.blog-vertical header.pix-heading-title h2,.pix-tittle,nav.navigation > ul > li:hover > a, nav.navigation > ul > li.current-menu-ancestor > a,.table tbody tr:hover,.widget_newsletter label .btn{
			background-color:#240347 !important;
		}
		.pix-bdrcolr ,.tabs.horizontal .nav-tabs li.active,.address-info .text,.subtitle h1,.about-us article .text,blockquote,
		.pagination > ul > li > a:before,.pagination > ul > li > a:before,.pagination > ul > li > span.active:before,.footer-icons .followus a:hover{
			border-color:#240347 !important;
		}
		#banner .flexslider figcaption .pix-desc h3 span {
		   box-shadow: -10px  0 0 #240347,10px  0 0 #240347 !important; 
 		}
		.our-team-sec article:hover figure figcaption .pix-post-title a{
			 box-shadow: -10px  0 0 #240347,10px  0 0 #240347 !important;   
		}
		header#header .top-head{
			background-color:#240347 !important;
		}
		nav.navigation > ul > li > a
		{
			color:#ffffff !important;
		}
		header #mainheader{
			background-color:#3a1c59 !important;
		}
		.sliderpagination ul li:before{
			border-color: transparent #240347 !important;
		}
		.footer-widget .widget_newsletter .error:before{
			border-top-color: #240347 !important;
		}
		</style>
				<div id="wrappermain-pix" class="wrapper wrapper_boxed">
		<!-- Header Start -->
        <header id="header">
            <!-- Top Head Start -->
            <div class="top-head">
            	<div class="container">
                    <!-- Logo -->
                    <div class="logo">
                        				<a href="http://www.roxwalkoff.com">
                	<img src="http://www.roxwalkoff.com/wp-content/uploads/2016/03/main-logo.png"  style="width:100%px; height:100%px" 
                    alt="Rox Walk Off: Colorado Rockies News and Fan Gathering Place" />
                </a>
	 		                    </div>
                    <!-- Logo Close -->
                                    </div>
            </div>
            <!-- Top Head End -->
            <div id="mainheader">
                <div class="container">
                    <!-- Right Header -->
                    <nav class="navigation">
                    	<a class="cs-click-menu"><i class="fa fa-bars"></i></a>
                        <ul id="menus"><li id="menu-item-465" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-465"><a href="http://www.roxwalkoff.com/">Home</a></li>
<li id="menu-item-15745" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15745"><a href="http://www.roxwalkoff.com/roxnews/">News</a></li>
<li id="menu-item-15916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15916"><a href="http://www.roxwalkoff.com/game-day/">GAME DAY</a></li>
<li id="menu-item-15846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15846"><a href="http://www.roxwalkoff.com/dr-cs-musings/">Dr. C’s Musings</a></li>
<li id="menu-item-15917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="http://www.roxwalkoff.com/soundoff/">SOUND OFF</a></li>
<li id="menu-item-15728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15728"><a href="http://www.roxwalkoff.com/category/hotplate/">Hot Stove</a></li>
<li id="menu-item-15729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15729"><a href="http://www.roxwalkoff.com/edtheump/">Edtheump</a></li>
<li id="menu-item-15730" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15730"><a href="http://www.roxwalkoff.com/donate/">Donate</a></li>
<li id="menu-item-15731" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15731"><a href="http://www.roxwalkoff.com/contact/">Contact</a></li>
</ul>                    </nav>
                    
                    <div class="rightheader">
                            
                                    <!-- Search Section -->    
                                    <div class="searcharea">
                                        <a class="btnsearch" href="#searchbox">
                                            <i class="fa fa-search"></i>
                                        </a>
                                    </div>
                                    <!-- Search Section Close--> 
                                                                     </div>
                    <!-- Right Header Close --> 
                                               <div id="searcharea">
                            <div class="searchform">
                                	<form id="searchform" method="get" action="http://www.roxwalkoff.com"  role="search">
		<button> <i class="fa fa-search"></i></button>
        <input name="s" id="searchinput" value="Search for:" type="text" />
    </form>
                               </div>
                        </div>
                                            </div>
            </div>
        </header>
    <!-- Header Close -->
    <div class="clear"></div>
    <div id="main">
        <!-- Inner Main -->
        <div id="innermain">
                                      <div class="container">
                <div class="row">
					                             <div class="breadcrumb"> 
                                <div class="breadcrumbs"><ul><li><a href="http://www.roxwalkoff.com/">Home</a></li><li><a href="http://www.roxwalkoff.com/category/dr-c-musings/">Dr. C's Musings</a></li><li class="pix-active">Current Page</li></ul></div>                            </div>
                    	                
                              <!--Left Sidebar Starts-->

		<!--Left Sidebar End-->
    <div class="col-md-12" >
    	<div class="subtitle"><h1 class="pix-page-title px-single-page-title">Is It Time to Panic Yet? Waiting for a Rockies Swoon&#8230;</h1></div>		<div class="blog blog_detail">
            <article>
                                <div class="pix-content-wrap">
                    <div class="detail_text rich_editor_text">
                     		<ul class="post-options">
        	        	                 <li>
                 	                    <time datetime="04-06-17">June 4, 2017</time>
                </li>
				<li><span>in</span> <a href="http://www.roxwalkoff.com/category/dr-c-musings/" rel="tag">Dr. C's Musings</a>, <a href="http://www.roxwalkoff.com/category/new-post/" rel="tag">New Post</a>, <a href="http://www.roxwalkoff.com/category/news/" rel="tag">News</a></li>		</ul>
	                    <p>The Rockies entered June still in first place…and would be there on June 4th if the Milwaukee bullpen could have held an 8-5 lead.</p>
<p>&nbsp;</p>
<p>In the past two weeks I have heard Ryan Spillbourghs and Pat Saunders of the Denver Post repeat my old dictum &#8211; everyone wins 60, everyone loses 60, it’s the other 42 that determine champions and who gets the first overall pick. Spilly&#8217;s quote had some math issues but…I appreciated hearing from two baseball people what I thought I had developed on my own (even in my chosen field of study I am an inveterate stealer of ideas and then forget they are someone elses).</p>
<p>&nbsp;</p>
<p>What has always been the issue is how do you know which 42 are which? Was the Rox blowing a multiple run lead in San Diego for the second time this season one of the 60 or the 42? And the three games against Seattle…which are those?</p>
<p>&nbsp;</p>
<p>Look, sometimes you just run into a team on a hot streak or starting one. I think what we saw against Washington back in April is a case of that (and while they are a great team, if the Rox played them the next week after the injury to Eaton or when Turner started to cool off, is that a 3-1 series in the Rox favor?).</p>
<p>&nbsp;</p>
<p>The Seattle series was very disappointing. They lost their first series in a month losing the home series 2-0, and then having to rely on Kyle Freeland and a big fly from Arenado to split the road series. And then they go out and blow the Friday game against the Padres. So…time to panic. The Rox woke up on Saturday out of first for essentially the first time in the season. Thankfully the Rox got a 2016 road start from Tyler Chatwood to give the Rox a chance on Sunday to have  a 3-4 week…nothing to really panic over. Of course if Hoffman gets shelled or Cozart shuts the bats down, it will be a 2-5 week and the Rox will be that much firther out of first. So maybe a game like Sunday the 4th of June is one of those 42.</p>
<p>&nbsp;</p>
<p>The last time I wrote I said that the starting rotation of the Rox and Dbacks had a better starting rotation than the Dodgers, and that the Rox has been, based at least on ERA-, the best of the division. The Dodgers have been searching for the combo to put with Kershaw, and Saturday showed that Rich Hill isn&#8217;t that man, at least this year. With Alex Wood going on the DL for at least 2-weeks they suspect, their rotation looks that much weaker. But the Rox rotation is the one that fell apart this past week.</p>
<p>&nbsp;</p>
<p>On Monday they got another awful home start from Tyler Chatwood. His control was awful (3 walks doesn&#8217;t capture how many spots he missed). For once the bullpen from start to finish was solid (4.2 innings of 3 hit, 3 walk scoreless ball). Tyler really does pitch more like a 5th starter &#8211; one game off, one game on. He needs to pitch as a #3 or #2…that is the level of his stuff. But…he just can&#8217;t do it consistently. The bats didn&#8217;t help with just 7-hits off a decent starter and a pretty good bullpen (Jerry Dipoto I still think is a very bright GM and he knows great defense and great bullpens are key to success).</p>
<p>&nbsp;</p>
<p>Then on Tuesday Tyler Anderson pitched like he did in April, not May. He&#8217;s now on the DL and I begin to wonder if a lengthy DL spell might be needed to do surgery on whatever is bad in his knee. And of course, as we saw last year with Jake McGee, you take away a solid base from a pitcher and the results fall apart. And knee injuries are not always quick fixes (in my 20s I had a non-ACL but substantial knee injury and I tried to run on it 6-weeks later and…it was a lost year). And once again, the offense sputtered, against a very average at best starter and the lessor arms of their bullpen, again only getting 7 hits.</p>
<p>&nbsp;</p>
<p>What was really disconcerting was the bullpen though. Otto is now on the DL. Who knows when he gets back and if back issues might explain why his control is so varied this week. Mike Dunn has been awful since going on the DL, leading me to think he&#8217;s not getting the same extension on his pitches since his back injury. And if that is true, this could be a long season if they don&#8217;t shut him down and let it get right. And Carlos Estevez was once again hit hard. 5 hits and 3 runs in an inning isn&#8217;t acceptable for any guy in the bullpen, and especially a guy with stuff like Estevez. Was his being rushed to the majors last year (and I agreed with doing it…he looked ready and they needed pen help to stay in the race) a factor in what we are seeing? Who knows, but with guys like Yancey Almonte (who a lot of scouts believe profiles better as a reliever despite his strong start in AA this year),  Jairo Diaz (who appears to be healthy but has been out of the minors dealing with &#8220;personal issues&#8221; &#8211; probably related to issues in Venezuela), and Sam Moll (a lefty who might be the best choice if Dunn has to go back on the DL), the window for Estevez to be considered an important bullpen arm might be closing (no pun intended).</p>
<p>&nbsp;</p>
<p>Then on Wednesday Senzatela wasn&#8217;t awful &#8211; 4 runs in 5 innings but with 7Ks. But he was hurt by some of the weaker hitters in their lineup. The issue on Wednesday was simply James Paxton wasn&#8217;t touched. He&#8217;s a great pitcher finally tapping into his potential with a sub-2 ERA. So the issues against Seattle yes highlighted weakness in their pitching but, a total of 18 hits in 3 games isn&#8217;t going to win many. Which is why the Friday start against the Padres from Marquez was so disappointing. Now yes, it is possible that the smash to his hand and thumb might have made him lose control of his fastball &#8211; he says today it is feeling fine. But when you have a 4-1 lead against the Padres, you have to win it. And when your team finally gets 13 hits, you have to win it. Marquez had been great the prior 4 starts…and this one, was an April start. And of course both Scott Oberg and Mike Dunn game up runs (Dunn, another homer). It didn&#8217;t help that with 10 hits the Rox scored just 4 runs off of Clayton Richard. And the heart of the Padres bullpen pretty much shut down the Rox afterwards.</p>
<p>&nbsp;</p>
<p>So, not a great week. But this club has gotten pretty good starting pitching on the road. They have generally hit on the road (the Paxton start and the one against the Twins Barrios being the exception but…great stuff when thrown great on a given night will shut down the &#8217;27 Yankees). So…is it time to panic?</p>
<p>&nbsp;</p>
<p>No. But Tyler Anderson&#8217;s knee needs to get better fast. Tyler Chatwood has to give 75% of his starts in the mode of Saturday not Monday. He has to be a staff leader. And he can be. We have to accept that there will be awful games with young starters (like Marquez on Friday), and ones that are limited (like Senzatela on Wednesday). But Kyle Freeland&#8217;s starts have been what you hope for from a rookie with his pedigree (and he might…stress might…be a bit better than scouts thought he was going to be &#8211; more of a 3rd starter than a 4th or 5th).</p>
<p>&nbsp;</p>
<p>The team has to get better if they are really going to push for the West Division title and the playoffs. The good news is that:</p>
<p>&nbsp;</p>
<ol>
<li>Jon Gray has thrown 12.1 innings</li>
<li>David Dahl has had 0 at-bats</li>
<li>Tom Murphy&#8217;s only at-bats began this weekend…in AAA</li>
<li>CarGo still has less homers than Yunel Escobar</li>
<li>And Trevor Story is still finding his groove.</li>
</ol>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Given that, and that the Dodgers are playing about as well as they can the past month and the Dbacks have had pretty solid health…maybe things are actually better than they appear.</p>
<p>&nbsp;</p>
<p>Maybe</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
                </div>
                    <!-- Share Post -->
                    <div class="share-post">
                                            </div>
                    <!-- Share Post Close -->
                    <div class="prev-nex-btn">
                    	        <div class="single-paginate">
			               <div class="next-post-paginate">
                <a href="http://www.roxwalkoff.com/regaining-sea-legs/" class="pix-colr"><i class="fa fa-arrow-left"></i>
                    Previous Post               </a>
               <h2 class="px-single-page-title">
                   Regaining Sea Legs               </h2>
               <ul>
               <li><a href="http://www.roxwalkoff.com/category/new-post/" rel="tag">New Post</a> <a href="http://www.roxwalkoff.com/category/news/" rel="tag">News</a></li>                <li>June 4, 2017</li>
               </ul>
               </div>
                        </div>
                             </div>
                </div>
                             </article>
            </div>
            
		        <div class="pix-content-wrap">
			<div id="comments">
				<header>
					<h2 class="heading-color section-title uppercase">
						1 Comment                    </h2>
				</header>
                <ul>
                	        <li  class="comment even thread-even depth-1" id="li-comment-194887">
            <div class="thumblist" id="comment-194887">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://0.gravatar.com/avatar/69ecbfbda43a05ffc1d50f3e73bba9f9?s=65&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/69ecbfbda43a05ffc1d50f3e73bba9f9?s=130&amp;d=identicon&amp;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover"><a href='http://Website' rel='external nofollow' class='url'>Bill</a></a></h5><br><span>June 5, 2017</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>Dr. C -. As always I enjoy your musings and just wish I had the time to read every one. One of these days things will settle down here. I agree with most of the things you mention above except for  your comment on Carlos Estevez. Yes he gave up 5 hits and 3 runs in an inning. But no he wasn&#8217;t hit hard. I can&#8217;t remember batter to batter or pitch to pitch but I what I do remember is most, if not all, the hits were bloops, bleeders and seeing eye hits. Now if he had his strike out pitch working we wouldn&#8217;t have to talk about it. But he pitched much better than 3 runs on 5 hits.</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/is-it-time-to-panic-yet-waiting-for-a-rockies-swoon/?replytocom=194887#respond' onclick='return addComment.moveForm( "comment-194887", "194887", "respond", "16968" )' aria-label='Reply to Bill'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
                </ul>
				 							</div>
           </div>
		        <div class="pix-content-wrap">
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/is-it-time-to-panic-yet-waiting-for-a-rockies-swoon/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.roxwalkoff.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment fullwidth"><textarea id="comment" name="comment"  aria-required="true" placeholder="Write comment" rows="4" cols="39"></textarea></p><!-- #form-section-comment .form-section --><p class="comment-notes">
                            </p>
<p class="comment-form-author"><label class="form-icons">
						<small class="fa fa-ellipsis-v"></small>
						<i class="fa fa-user"></i>
						
					</label>
					<input id="author" name="author" class="nameinput" type="text" value="Name" size="30" tabindex="1"  /><span>(required)</span></p><!-- #form-section-author .form-section -->
<p class="comment-form-email"><label class="form-icons">
						<small class="fa fa-ellipsis-v"></small>
						<i class="fa fa-envelope"></i>
					</label><input id="email" name="email" class="emailinput" type="text"  value="Email" size="30" tabindex="2"/><span>(required)</span></p><!-- #form-section-email .form-section -->
<p class="comment-form-website"><label class="form-icons">
						<small class="fa fa-ellipsis-v"></small>
						<i class="fa fa-phone"></i>
					</label><input id="url" name="url" type="text" class="websiteinput"  value="Website" size="30" tabindex="3" /><span>(required)</span></p><!-- #<span class="hiddenSpellError" pre="">form-section-url</span> .form-section -->
<p class="form-submit"><div  id="g-recaptcha-0" class="g-recaptcha" data-sitekey="6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob" data-theme="light"></div><noscript><div style="width: 302px; height: 462px;"><div style="width: 302px; height: 422px; position: relative;"><div style="width: 302px; height: 422px; position: absolute;"><iframe src="https://www.google.com/recaptcha/api/fallback?k=6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe></div></div><div style="width: 300px; height: 60px; border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px;"><textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px; height: 40px; border: 1px solid #c1c1c1; margin: 10px 25px; padding: 0px; resize: none;" value=""></textarea></div></div><br><br></noscript><input name="submit" type="submit" id="submit-comment" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='16968' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="59d46bc315" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="6"/></p>			</form>
			</div><!-- #respond -->
				</div>
     </div>
                     </div>
            </div> 
                             </div>
    	<!-- Inner Main -->
    </div>
    <div class="footer-widget">
            	<div class="container">
        	            <div class="footer-icons">
                <div class="followus">                    	<a title="" href="http://facebook.com/roxwalkoff" data-original-title="Facebook" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-facebook-square icon"></i></a>
					                    	<a title="" href="https://twitter.com/roxWalkOff" data-original-title="Twitter" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-twitter-square icon"></i></a>
					</div>            </div>
        </div>
                <!-- Container Start -->
                <div class="container">
            <!-- Footer Widgets Start -->
            <div class="widget widget_nav_menu"><header class="px-heading-title"><h2 class="px-section-title">Quick Links</h2></header><div class="menu-roxmenu-container"><ul id="menu-roxmenu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-465"><a href="http://www.roxwalkoff.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15745"><a href="http://www.roxwalkoff.com/roxnews/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15916"><a href="http://www.roxwalkoff.com/game-day/">GAME DAY</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15846"><a href="http://www.roxwalkoff.com/dr-cs-musings/">Dr. C’s Musings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="http://www.roxwalkoff.com/soundoff/">SOUND OFF</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15728"><a href="http://www.roxwalkoff.com/category/hotplate/">Hot Stove</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15729"><a href="http://www.roxwalkoff.com/edtheump/">Edtheump</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15730"><a href="http://www.roxwalkoff.com/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15731"><a href="http://www.roxwalkoff.com/contact/">Contact</a></li>
</ul></div></div>		<div class="widget widget_recent_entries">		<header class="px-heading-title"><h2 class="px-section-title">Latest Blog</h2></header>		<ul>
					<li>
				<a href="http://www.roxwalkoff.com/is-it-time-to-panic-yet-waiting-for-a-rockies-swoon/">Is It Time to Panic Yet? Waiting for a Rockies Swoon&#8230;</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/regaining-sea-legs/">Regaining Sea Legs</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/rockies-2017-regular-season-13-over-lets-analyze/">2017 Regular Season 1/3 Complete &#8211; Let&#8217;s Analyze</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/eighth-inning-death-knell-for-cardinals/">Eighth Inning Death Knell For Cardinals</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/rockies-changing-the-expectations-game/">Rockies Changing The &#8220;Expectations&#8221; Game</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/rockies-go-7-3-on-longest-road-trip-of-season/">Rockies Go 7-3 on Longest Road Trip of Season</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/contenders-now-what-comes-next/">Contenders! Now what comes next?</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/road-worthy/">ROAD WORTHY</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/is-baseball-all-about-winning-series/">Is Baseball All About Winning Series?</a>
						</li>
					<li>
				<a href="http://www.roxwalkoff.com/series-win-on-leg-one-of-long-trip/">Series Win on Leg One of Long Trip</a>
						</li>
				</ul>
		</div>		<div class="widget widget_categories"><header class="px-heading-title"><h2 class="px-section-title">Categories</h2></header>		<ul>
	<li class="cat-item cat-item-614"><a href="http://www.roxwalkoff.com/category/10-season-reviews/" >10% Season Reviews</a> (8)
</li>
	<li class="cat-item cat-item-12"><a href="http://www.roxwalkoff.com/category/aroundtheleague/" title="News on other players Around the League...">Around the League</a> (42)
</li>
	<li class="cat-item cat-item-616"><a href="http://www.roxwalkoff.com/category/dr-c-musings/" title="An area for Dr. C&#039;s Awesome Musings!">Dr. C&#039;s Musings</a> (48)
</li>
	<li class="cat-item cat-item-163"><a href="http://www.roxwalkoff.com/category/gameday/" title="Game Day Posts">Game Day</a> (723)
</li>
	<li class="cat-item cat-item-613"><a href="http://www.roxwalkoff.com/category/give-your-feedback/" >Give Your Feedback</a> (3)
</li>
	<li class="cat-item cat-item-14"><a href="http://www.roxwalkoff.com/category/hotplate/" title="Trade rumors and realities">Hot Stove</a> (66)
</li>
	<li class="cat-item cat-item-162"><a href="http://www.roxwalkoff.com/category/keydates/" title="Important Dates for the Rox">Key Dates</a> (6)
</li>
	<li class="cat-item cat-item-694"><a href="http://www.roxwalkoff.com/category/new-post/" title="all new post">New Post</a> (170)
</li>
	<li class="cat-item cat-item-3"><a href="http://www.roxwalkoff.com/category/news/" title="Rox news from around the interweb.">News</a> (734)
</li>
	<li class="cat-item cat-item-421"><a href="http://www.roxwalkoff.com/category/post-game/" >Post Game</a> (385)
</li>
	<li class="cat-item cat-item-388"><a href="http://www.roxwalkoff.com/category/quick-news/" >Quick News</a> (54)
</li>
	<li class="cat-item cat-item-243"><a href="http://www.roxwalkoff.com/category/farm/" title="Coverage of Rockies Farm Teams">Rox Farm Report</a> (12)
</li>
	<li class="cat-item cat-item-13"><a href="http://www.roxwalkoff.com/category/quick-news/spring-training/soundoff/" title="Your thoughts on the Rox">Sound Off</a> (281)
</li>
	<li class="cat-item cat-item-412"><a href="http://www.roxwalkoff.com/category/quick-news/spring-training/" >Spring Training</a> (36)
</li>
	<li class="cat-item cat-item-615"><a href="http://www.roxwalkoff.com/category/statistics/" >Statistics</a> (9)
</li>
	<li class="cat-item cat-item-442"><a href="http://www.roxwalkoff.com/category/walk-off/" >WALK OFF</a> (30)
</li>
	<li class="cat-item cat-item-441"><a href="http://www.roxwalkoff.com/category/week-in-review/" >Week in Review</a> (10)
</li>
		</ul>
</div><div class="widget widget_wp_sidebarlogin"><header class="px-heading-title"><h2 class="px-section-title">Login</h2></header>
		<form name="loginform" id="loginform" action="http://www.roxwalkoff.com/roxwalkoff-admin" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Login &rarr;" />
				<input type="hidden" name="redirect_to" value="http://www.roxwalkoff.com/is-it-time-to-panic-yet-waiting-for-a-rockies-swoon/" />
			</p>
			
		</form><ul class="pagenav sidebar_login_links"><li class="register-link"><a href="http://www.roxwalkoff.com/roxwalkoff-admin?action=register">Register</a></li><li class="lost_password-link"><a href="http://www.roxwalkoff.com/roxwalkoff-admin?action=lostpassword">Lost Password</a></li></ul></div>            <!-- Footer Widgets End -->
        </div>
                <!-- Container End -->
    	<footer id="footer">
            <div class="container">
                <p class="coptyright">
                    ©2016 Rox Walk Off: Colorado Rockies News and Fan Gathering Place All Rights Reserved.                </p>
                <!--<a href="" class="btn btngotop"><i class="fa fa-arrow-circle-o-up"></i></a>-->
            </div>
        </footer>
    </div>
</div>
<!-- Wrapper End -->

<!-- BEGIN recaptcha, injected by plugin wp-recaptcha-integration  -->
<script type="text/javascript">
				function get_form_submits(el){
					var form,current=el,ui,type,slice = Array.prototype.slice,self=this;
					this.submits=[];
					this.form=false;

					this.setEnabled=function(e){
						for ( var s=0;s<self.submits.length;s++ ) {
							if (e) self.submits[s].removeAttribute('disabled');
							else  self.submits[s].setAttribute('disabled','disabled');
						}
						return this;
					};
					while ( current && current.nodeName != 'BODY' && current.nodeName != 'FORM' ) {
						current = current.parentNode;
					}
					if ( !current || current.nodeName != 'FORM' )
						return false;
					this.form=current;
					ui=slice.call(this.form.getElementsByTagName('input')).concat(slice.call(this.form.getElementsByTagName('button')));
					for (var i = 0; i < ui.length; i++) if ( (type=ui[i].getAttribute('TYPE')) && type=='submit' ) this.submits.push(ui[i]);
					return this;
				}
				</script><script type="text/javascript">
		var recaptcha_widgets={};
		function wp_recaptchaLoadCallback(){ 
			try {
				grecaptcha;
			} catch(err){
				return;
			}
			var e = document.querySelectorAll ? document.querySelectorAll('.g-recaptcha:not(.wpcf7-form-control)') : document.getElementsByClassName('g-recaptcha'),
				form_submits;

			for (var i=0;i<e.length;i++) {
				(function(el){
					var form_submits = get_form_submits(el).setEnabled(false), wid;
					// check if captcha element is unrendered
					if ( ! el.childNodes.length) {
						wid = grecaptcha.render(el,{
							'sitekey':'6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob',
							'theme':el.getAttribute('data-theme') || 'light'
							,
							'callback' : function(r){ get_form_submits(el).setEnabled(true); /* enable submit buttons */ }
						});
						el.setAttribute('data-widget-id',wid);
					} else {
						wid = el.getAttribute('data-widget-id');
						grecaptcha.reset(wid);
					}
				})(e[i]);
			}
		}
		
		// if jquery present re-render jquery/ajax loaded captcha elements 
		if ( typeof jQuery !== 'undefined' )
			jQuery(document).ajaxComplete( function(evt,xhr,set){
				if( xhr.responseText && xhr.responseText.indexOf('6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob') !== -1)
					wp_recaptchaLoadCallback();
			} );
		
		</script><script src="https://www.google.com/recaptcha/api.js?onload=wp_recaptchaLoadCallback&#038;render=explicit" async defer></script>
<!-- END recaptcha -->
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/comment-reply.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/blankshield/blankshield.min.js?ver=4070'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/block-tabnapping.js?ver=4070'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.22.0'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/bootstrap.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/modernizr.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/jquery.prettyphoto.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
</body>
</html>
