<!DOCTYPE html>
<html lang="en-US">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta charset="UTF-8" />
	<link rel="shortcut icon" href="http://www.roxwalkoff.com/wp-content/uploads/2016/03/fav-icon.png" />
	
    <!--[if lt IE 9]><script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
	<title>RUMBLIN,&#8217; STUMBLIN,&#8217; BREAKIN&#8217; EVEN &#8211; Rox Walk Off: Colorado Rockies News and Fan Gathering Place</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0"><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Rox Walk Off: Colorado Rockies News and Fan Gathering Place &raquo; Feed" href="http://www.roxwalkoff.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rox Walk Off: Colorado Rockies News and Fan Gathering Place &raquo; Comments Feed" href="http://www.roxwalkoff.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rox Walk Off: Colorado Rockies News and Fan Gathering Place &raquo; RUMBLIN,&#8217; STUMBLIN,&#8217; BREAKIN&#8217; EVEN Comments Feed" href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.roxwalkoff.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bwp-rc-css'  href='http://www.roxwalkoff.com/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.roxwalkoff.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://www.roxwalkoff.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.1.6' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='sidebar-login-css'  href='http://www.roxwalkoff.com/wp-content/plugins/sidebar-login/assets/css/sidebar-login.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='style_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/style.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='custom_css_roxwall-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/custom_roxwallcss.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/prettyphoto.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/bootstrap.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/font-awesome.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://www.roxwalkoff.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.6-78496d1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://www.roxwalkoff.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='responsive_css-css'  href='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/css/responsive.css?ver=4.9.5' type='text/css' media='all' />
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/bwp-recent-comments/js/bwp-rc-ajax.js?ver=1.2.2'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.1.6'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.1.6'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/sidebar-login/assets/js/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"http:\/\/www.roxwalkoff.com\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"0","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar_login_error"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/sidebar-login/assets/js/sidebar-login.min.js?ver=2.7.3'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/functions.js?ver=4.9.5'></script>
<link rel='https://api.w.org/' href='http://www.roxwalkoff.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.roxwalkoff.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.roxwalkoff.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Nolan Freed From Suspension' href='http://www.roxwalkoff.com/nolan-freed-from-suspension/' />
<meta name="generator" content="WordPress 4.9.5" />
<link rel="canonical" href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/" />
<link rel='shortlink' href='http://www.roxwalkoff.com/?p=17266' />
<link rel="alternate" type="application/json+oembed" href="http://www.roxwalkoff.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.roxwalkoff.com%2Frumblin-stumblin-breakin-even%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.roxwalkoff.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.roxwalkoff.com%2Frumblin-stumblin-breakin-even%2F&#038;format=xml" />

<!-- BEGIN recaptcha, injected by plugin wp-recaptcha-integration  -->

<!-- END recaptcha -->
<script type="text/javascript">
	var bwp_ajax_url = 'http://www.roxwalkoff.com/';
</script>
<meta name="generator" content="Powered by Slider Revolution 5.1.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
    </head>
	<body class="post-template-default single single-post postid-17266 single-format-standard" style="background:url(http://www.roxwalkoff.com/wp-content/uploads/2016/03/rwoBack1.jpg) no-repeat  center 	fixed" style="background:#e95842 url()"  >
 				<style type="text/css">
		.pix-colr, .pix-colrhvr:hover,.price-table article:hover h3,.breadcrumbs ul li.pix-active,#footer p a:hover,.is-countdown span:before,.pagination .active,
/* New Clases Add*/.event-listing article:hover .text .pix-post-title a,.cs-post-title a,.pagination .active,.blog-medium-options li a,.is-countdown span,.widget ul li:hover a { color:#240347 !important;
		}
		.pix-bgcolr,.pix-bgcolrhvr:hover,nav.navigation > ul > li > a:before,.cart-sec span,.navigation ul ul li:hover > a,.navigation ul > li.current-menu-item > a,
		.navigation ul ul li.current-menu-item > a,.price-table article:hover .pix-price-box, .event.evevt-listing article:hover .text .btn-boobked, .match-result.match-lost p,.event.event-listing.event-listing-v2 article:hover,.cycle-pager-active,.widget .tagcloud a:hover, .event.event-listing article:hover .text .btn-boobked, .flex-direction-nav li a:hover /**/, .our-team-sec article:hover figure figcaption .pix-post-title a,.footer-widget .widget_newsletter .error,.news-section article:hover .text,.password_protected form input[type="submit"],.team-vertical article figcaption .caption h2,
#respond form input[type="submit"],#wp-calendar caption,.gallery ul li figure figcaption a,.woocommerce-pagination ul li a:hover,.woocommerce-pagination ul li span,.woocommerce-tabs .tabs .active a, span.match-category.cat-neutral, .event.event-listing article:hover .text .btn,.widget_search form input[type="submit"], .woocommerce .button,.onsale,.gallery ul li:hover .text,.footer-icons .followus a:hover,
/* New Clases Add*/.searchform button,.tabs.horizontal .nav-tabs li.active a,p.stars span a.active,.event.event-listing.event-listing-v2 .btn-viewall,.featured-title,
.pix-feature article .blog-bottom .btn,.pix-feature .featured,.blog-vertical .tab-content header.pix-heading-title h2,header #lang_sel a:hover, header #lang_sel ul ul a:hover,
.post-tags a:hover,.blog-vertical header.pix-heading-title h2,.pix-tittle,nav.navigation > ul > li:hover > a, nav.navigation > ul > li.current-menu-ancestor > a,.table tbody tr:hover,.widget_newsletter label .btn{
			background-color:#240347 !important;
		}
		.pix-bdrcolr ,.tabs.horizontal .nav-tabs li.active,.address-info .text,.subtitle h1,.about-us article .text,blockquote,
		.pagination > ul > li > a:before,.pagination > ul > li > a:before,.pagination > ul > li > span.active:before,.footer-icons .followus a:hover{
			border-color:#240347 !important;
		}
		#banner .flexslider figcaption .pix-desc h3 span {
		   box-shadow: -10px  0 0 #240347,10px  0 0 #240347 !important; 
 		}
		.our-team-sec article:hover figure figcaption .pix-post-title a{
			 box-shadow: -10px  0 0 #240347,10px  0 0 #240347 !important;   
		}
		header#header .top-head{
			background-color:#240347 !important;
		}
		nav.navigation > ul > li > a
		{
			color:#ffffff !important;
		}
		header #mainheader{
			background-color:#3a1c59 !important;
		}
		.sliderpagination ul li:before{
			border-color: transparent #240347 !important;
		}
		.footer-widget .widget_newsletter .error:before{
			border-top-color: #240347 !important;
		}
		</style>
				<div id="wrappermain-pix" class="wrapper wrapper_boxed">
		<!-- Header Start -->
        <header id="header">
            <!-- Top Head Start -->
            <div class="top-head">
            	<div class="container">
                    <!-- Logo -->
                    <div class="logo">
                        				<a href="http://www.roxwalkoff.com">
                	<img src="http://www.roxwalkoff.com/wp-content/uploads/2016/03/main-logo.png"  style="width:100%px; height:100%px" 
                    alt="Rox Walk Off: Colorado Rockies News and Fan Gathering Place" />
                </a>
	 		                    </div>
                    <!-- Logo Close -->
                                    </div>
            </div>
            <!-- Top Head End -->
            <div id="mainheader">
                <div class="container">
                    <!-- Right Header -->
                    <nav class="navigation">
                    	<a class="cs-click-menu"><i class="fa fa-bars"></i></a>
                        <ul id="menus"><li id="menu-item-465" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-465"><a href="http://www.roxwalkoff.com/">Home</a></li>
<li id="menu-item-15745" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15745"><a href="http://www.roxwalkoff.com/roxnews/">News</a></li>
<li id="menu-item-15916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15916"><a href="http://www.roxwalkoff.com/game-day/">GAME DAY</a></li>
<li id="menu-item-15846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15846"><a href="http://www.roxwalkoff.com/dr-cs-musings/">Dr. C’s Musings</a></li>
<li id="menu-item-15917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="http://www.roxwalkoff.com/soundoff/">SOUND OFF</a></li>
<li id="menu-item-15728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15728"><a href="http://www.roxwalkoff.com/category/hotplate/">Hot Stove</a></li>
<li id="menu-item-15729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15729"><a href="http://www.roxwalkoff.com/edtheump/">Edtheump</a></li>
<li id="menu-item-15730" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15730"><a href="http://www.roxwalkoff.com/donate/">Donate</a></li>
<li id="menu-item-15731" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15731"><a href="http://www.roxwalkoff.com/contact/">Contact</a></li>
</ul>                    </nav>
                    
                    <div class="rightheader">
                            
                                    <!-- Search Section -->    
                                    <div class="searcharea">
                                        <a class="btnsearch" href="#searchbox">
                                            <i class="fa fa-search"></i>
                                        </a>
                                    </div>
                                    <!-- Search Section Close--> 
                                                                     </div>
                    <!-- Right Header Close --> 
                                               <div id="searcharea">
                            <div class="searchform">
                                	<form id="searchform" method="get" action="http://www.roxwalkoff.com"  role="search">
		<button> <i class="fa fa-search"></i></button>
        <input name="s" id="searchinput" value="Search for:" type="text" />
    </form>
                               </div>
                        </div>
                                            </div>
            </div>
        </header>
    <!-- Header Close -->
    <div class="clear"></div>
    <div id="main">
        <!-- Inner Main -->
        <div id="innermain">
                                      <div class="container">
                <div class="row">
					                             <div class="breadcrumb"> 
                                <div class="breadcrumbs"><ul><li><a href="http://www.roxwalkoff.com/">Home</a></li><li><a href="http://www.roxwalkoff.com/category/new-post/">New Post</a></li><li class="pix-active">Current Page</li></ul></div>                            </div>
                    	                
                              <!--Left Sidebar Starts-->

		<!--Left Sidebar End-->
    <div class="col-md-9" >
    	<div class="subtitle"><h1 class="pix-page-title px-single-page-title">RUMBLIN,&#8217; STUMBLIN,&#8217; BREAKIN&#8217; EVEN</h1></div>		<div class="blog blog_detail">
            <article>
                                <figure>
                    <img src="http://www.roxwalkoff.com/wp-content/uploads/2018/04/IMG_0161.jpg" alt="RUMBLIN,&#8217; STUMBLIN,&#8217; BREAKIN&#8217; EVEN">
                </figure>
                                <div class="pix-content-wrap">
                    <div class="detail_text rich_editor_text">
                     		<ul class="post-options">
        	                <li class="featured">
                    
                    Featured		         
                 </li>
		        	                 <li>
                 	                    <time datetime="23-04-18">April 23, 2018</time>
                </li>
				<li><span>in</span> <a href="http://www.roxwalkoff.com/category/new-post/" rel="tag">New Post</a>, <a href="http://www.roxwalkoff.com/category/news/" rel="tag">News</a></li>		</ul>
	                    <h3>PADRES IN TOWN FOR 3 IN ADVANCE OF TRIP TO TROPICS</h3>
<p>The Colorado Rockies headed out of Washington, DC under a head of steam, having taken 3 of 4 from the Nationals, and set about sustaining the run with wins Monday and Tuesday over the Pirates in Pittsburgh under miserable conditions, then got knocked-about Wednesday afternoon before flying back to Colorado for 3 at Coors Field against the Chicago Cubs.  Chicago got the win under more crappy weather on Friday; the Rox retaliated Saturday, then with a sold-out park and spectacular Colorado spring conditions Sunday, failed to muster a sufficient comeback, dropping the weekend set to the Cubs.</p>
<p>They&#8217;re back at Coors Field tonight.  It&#8217;s Chad Bettis (3-0, 1.44) toeing-up against Brian Mitchell (0-2, 5.03) of the San Diego Padres in a battle of right-handers.  The Padres are in Denver for 3 before an off-day Thursday prior to a 3-day visit to Miami, Florida on the weekend.</p>
<p>A week ago tonight the Rockies got out to a 5-0 lead after 4 behind German Marquez.  They took a 2-0 lead in the 1st on a DJ LeMahieu walk and Chris Iannetta double, then with 1-out in the 4th Ian Desmond walked, Carlos Gonzalez singled, and Trevor Story, &#8220;Air,&#8221; made contact, driving the runners home with his 4th 2018 homer, a line-shot to left.  Pittsburgh tallied single runs off Marquez in the 5th and 6th before Chris Rusin and Adam Ottavino came-on and laid down the hammer.  Charlie Blackmon blasted home run no. 7, a solo-shot in the 8th, to nail-down a 6-2 victory.</p>
<p>Tonight&#8217;s starter, Bettis, was out on Tuesday and turned-in a 7-1/3 inning masterpiece.  His offense was selective, at best, scratching-out single runs on a walk, Blackmon single, and force-play in the opening inning, then another in the 4th on walks to Desmond and Gonzalez followed by a double from Air, who actually had an excellent week, logging 9 hits and 6 RBI to go with a relatively tame 5 strikeouts.  Bettis held the Pirates scoreless on 5 hits and 2 walks while striking-out 3.  Brian Shaw and Jake McGee each handled a batter in the 8th before Wade Davis came on for his 8th save.  Pittsburgh got loose on Kyle Freeland after 3 the next day.  Sean Rodriguez hit a 2-run homer in a 3-run 4th, and singles by Adam Frazier and Jordy Mercer leading-off the 5th chased the left-hander in favor of Scott Oberg, who couldn&#8217;t subdue the Bucs further.  3 more crossed the plate on a Josh Bell single and David Freese double.  The Pirates added another in the 6th and 3 more in the 8th off left-hander Mike Dunn, running-out to a 10-3 win.</p>
<p>Following a day-off Thursday another drubbing was in the cards for Friday.  Agbayani&#8217;s latest project, Jon Gray, made it into the 6th, but it wasn&#8217;t pretty.  The Cubs tallied 2 in the 1st, another in the 3rd and 2 more in the 5th before Gray opened the 6th surrendering a single to Addison Russell and a triple to Jason Hayward.  Gray gave way to Shaw, who had no answers, and 29 pitches later Chicago had 7 for the inning on their way to a 16-5 laugher.  But Colorado regrouped Saturday.  Tyler Anderson turned-in 6, 5 scoreless after spotting the Cubs 2 in the 1st.  The Rockies scored all 5 of their runs in the 5th after 2 were out.  With Mike Tauchman and Anderson on after bases-on-balls, LeMahieu doubled-in Tauchman, Gerardo Parra singled-in Anderson and LeMahieu, and after Blackmon, &#8220;Chuck Nazty,&#8221; walked, a single by Nolan Arenado and double by Air made it 5-2 Colorado.  Anderson, McGee, Ottavino, and Davis shut-down the Cubs from there.</p>
<p>Gonzalez had pulled a hamstring making a fine catch Wednesday afternoon, and by Sunday was placed on the 10-day DL.  Parra elected to accept his 4-game suspension from the April 11 fight with San Diego, Tauchman was demoted to AAA Albuquerque, and David Dahl and Noel Cuevas, a right-handed outfielder in apparent violation of the Rockies&#8217; Charter, were recalled from the Isotopes.  The Cubs refused to be intimidated, running-out to a 6-0 lead over Marquez, who looked sharp until beaning Kris Bryant and losing his mojo with 2-out in the 1st.  The right-hander departed with 1-out in the 4th.  Colorado rallied with 2 in the bottom of the 3rd, and another pair in the 5th on Blackmon and Arenado home runs.  A botched wheel play followed by a Javier Baez double moved Chicago back-out to 9-4 in the top of the 7th, but Colorado answered with 3-back in the bottom of the inning.  Nevertheless, Carl Edwards, Jr. and Brandon Morrow had little sense of humor finishing matters out.  2-out singles by Arenado and Story and a walk to Dahl had no effect in the 9th when Arenado was thrown out at the plate on a single by Desmond.</p>
<p>The Rockies are looking more and more like they will be very difficult to deal with, as long as they can get out ahead and nurse the young starting pitchers into the 6th.  Rusin, and unexpectedly, Ottavino, have emerged as ferocious additions to the McGee-Shaw-Davis bullpen triumvirate RMH has christened &#8220;MSD.&#8221;  So far it&#8217;s getting there, with the lead, that&#8217;s proving to be a challenge.</p>
<p>Bettis continues to demonstrate outstanding leadership for the young staff, and he and Mitchell are set to face off down at Coors at 6:40 MT.  Manager Bud Black has edged-away from returning Chuck N to the lead-off slot, now pushing him back into the 2-hole, essentially a swap with LeMahieu, the logic of which escapes me for the time being.  Dahl is now apparently set to be the moose, he&#8217;s hitting cleanup ahead of Air and Desmond.  It&#8217;s week 4.5.  Time to keep a-rumblin.&#8217;</p>
                </div>
                    <!-- Share Post -->
                    <div class="share-post">
                        <ul class="social-network"><a class="addthis_button_compact btn share-now pix-bgcolr"><i class="fa fa-share-square-o"></i>Share Now</a></ul>                    </div>
                    <!-- Share Post Close -->
                    <div class="prev-nex-btn">
                    	        <div class="single-paginate">
			               <div class="next-post-paginate">
                <a href="http://www.roxwalkoff.com/nolan-freed-from-suspension/" class="pix-colr"><i class="fa fa-arrow-left"></i>
                    Previous Post               </a>
               <h2 class="px-single-page-title">
                   Nolan Freed From Suspension               </h2>
               <ul>
               <li><a href="http://www.roxwalkoff.com/category/new-post/" rel="tag">New Post</a> <a href="http://www.roxwalkoff.com/category/news/" rel="tag">News</a></li>                <li>April 23, 2018</li>
               </ul>
               </div>
                        </div>
                             </div>
                </div>
                             </article>
            </div>
                	<!-- About Author -->
        <div class="pix-content-wrap">   
        	<div class="about-author">
                <!-- Thumbnail List Start -->
                <!-- Thumbnail List Item Start -->
                 <figure><a href="http://www.roxwalkoff.com/author/jim-miller/" class="float-left"><img alt='' src='http://0.gravatar.com/avatar/33ea21c76c5eecc66dc186de871e9b68?s=90&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/33ea21c76c5eecc66dc186de871e9b68?s=180&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-90 photo' height='90' width='90' /></a></figure>
                 <div class="text">
                    <h2><a class="colrhover" href="http://www.roxwalkoff.com/author/jim-miller/">jim-miller</a></h2>
                    <span></span>
                    <p>Architectural Spec Writer
Born Toledo, Ohio 4-9-55
Tiger Fan
Braves Fan
Rockies Fan</p>
                    <div class="followus">
                                                                                                                                    		</div>
                </div>
            </div>
        </div>    
       <!-- About Author End -->
    
		        <div class="pix-content-wrap">
			<div id="comments">
				<header>
					<h2 class="heading-color section-title uppercase">
						9 Comments                    </h2>
				</header>
                <ul>
                	        <li  class="comment byuser comment-author-sd_carp even thread-even depth-1" id="li-comment-195991">
            <div class="thumblist" id="comment-195991">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=65&#038;d=identicon&#038;r=pg' srcset='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover">sdcarp</a></h5><br><span>April 23, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>Full disclosure&#8230;.I’m heavily invested in this game with my Fantasy team.<br />
Arenado $59<br />
DJ $23 (a steal)<br />
Franchy Cordero $1 (taxi round)<br />
Pirela $1<br />
Galvis $1</p>
<p>Also heavily invested in the A’s&#8230;.including Sean Menea ($1).</p>
<p>I always end up with a west coast team.</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195991#respond' onclick='return addComment.moveForm( "comment-195991", "195991", "respond", "17266" )' aria-label='Reply to sdcarp'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
        <li  class="comment byuser comment-author-rockymountainhigh odd alt thread-odd thread-alt depth-1" id="li-comment-195992">
            <div class="thumblist" id="comment-195992">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=65&#038;d=identicon&#038;r=pg' srcset='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover">rockymountainhigh</a></h5><br><span>April 23, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>I think we see the MOD Squad tonight. (McGee, Otto, Davis)</p>
<p>Otto replaces Shaw, thereby changing the nickname for backend of bullpen. </p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195992#respond' onclick='return addComment.moveForm( "comment-195992", "195992", "respond", "17266" )' aria-label='Reply to rockymountainhigh'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
        <li  class="comment byuser comment-author-rockymountainhigh even thread-even depth-1" id="li-comment-195993">
            <div class="thumblist" id="comment-195993">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=65&#038;d=identicon&#038;r=pg' srcset='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover">rockymountainhigh</a></h5><br><span>April 23, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>Never mind MSD High Crew or the MOD Squad. We&#8217;re down to just Otto and Davis as reliable relievers.</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195993#respond' onclick='return addComment.moveForm( "comment-195993", "195993", "respond", "17266" )' aria-label='Reply to rockymountainhigh'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
        <li  class="comment byuser comment-author-sd_carp odd alt thread-odd thread-alt depth-1" id="li-comment-195994">
            <div class="thumblist" id="comment-195994">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=65&#038;d=identicon&#038;r=pg' srcset='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover">sdcarp</a></h5><br><span>April 24, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>Franchy Cordero&#8230;&#8230;what an athlete! The Padres are LOADED with offensive Prospects. Wait until you guys see Luis Urias and Fernando Tatis Jr.</p>
<p>Stat of the day:<br />
Never in baseball history has there been a month with more K’s than hits. Never. Entering yesterday’s game&#8230;&#8230;April 2018 5500 K’s, 5100 hits.</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195994#respond' onclick='return addComment.moveForm( "comment-195994", "195994", "respond", "17266" )' aria-label='Reply to sdcarp'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
        <li  class="comment even thread-even depth-1" id="li-comment-195995">
            <div class="thumblist" id="comment-195995">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=65&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover"><a href='http://Website' rel='external nofollow' class='url'>Bob K.</a></a></h5><br><span>April 24, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>I believe it is time to end the Oberg experiment.</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195995#respond' onclick='return addComment.moveForm( "comment-195995", "195995", "respond", "17266" )' aria-label='Reply to Bob K.'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	<ul class="children">
        <li  class="comment byuser comment-author-rockymountainhigh odd alt depth-2" id="li-comment-195996">
            <div class="thumblist" id="comment-195996">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=65&#038;d=identicon&#038;r=pg' srcset='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover">rockymountainhigh</a></h5><br><span>April 24, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>I agree, Bob K.</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195996#respond' onclick='return addComment.moveForm( "comment-195996", "195996", "respond", "17266" )' aria-label='Reply to rockymountainhigh'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
        <li  class="comment even thread-odd thread-alt depth-1" id="li-comment-195997">
            <div class="thumblist" id="comment-195997">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=65&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover"><a href='http://Website' rel='external nofollow' class='url'>Bob K.</a></a></h5><br><span>April 24, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>Oberg optioned to AAA and Zach Jemiola DFAed to make room for Brooks Pounders.</p>
<p><a href="https://www.mlbtraderumors.com/2018/04/rockies-select-brooks-pounders-dfa-zach-jemiola.html" rel="nofollow">https://www.mlbtraderumors.com/2018/04/rockies-select-brooks-pounders-dfa-zach-jemiola.html</a></p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195997#respond' onclick='return addComment.moveForm( "comment-195997", "195997", "respond", "17266" )' aria-label='Reply to Bob K.'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	<ul class="children">
        <li  class="comment byuser comment-author-sd_carp odd alt depth-2" id="li-comment-195998">
            <div class="thumblist" id="comment-195998">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=65&#038;d=identicon&#038;r=pg' srcset='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover">sdcarp</a></h5><br><span>April 25, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>I’m not impressed (never have been) with Pounders. Perhaps he is placeholder until Hoffman is ready then one of the SPers goes into this slot????????</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195998#respond' onclick='return addComment.moveForm( "comment-195998", "195998", "respond", "17266" )' aria-label='Reply to sdcarp'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
        <li  class="comment even thread-even depth-1" id="li-comment-195999">
            <div class="thumblist" id="comment-195999">
                <ul>
                    <li>
                        <figure>
                            <a href="#"><img alt='' src='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=65&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=130&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-65 photo' height='65' width='65' /></a>
                        </figure>
                         <div class="text">
                          <header>
                                <h5><a class="colrhover"><a href='http://Website' rel='external nofollow' class='url'>Bob K.</a></a></h5><br><span>April 25, 2018</span><br/>                          </header>
                          <div class="bottom-comment">
							  <p>Winkler is finally healthy and been on the Braves 25 man roster long enough that he now fully belongs to the Braves.<br />
From MLBTrade Rumors:<br />
&#8220;Dan Winkler, RHP, Braves: Winkler’s Rule 5 status carried over all the way back to the 2014 Rule 5 Draft, as his career with the Braves has been beset by injuries. Winkler, at long last, is healthy and has seen that status expire, meaning the Braves could option him without exposing him to waivers first. Of course, with a 1.59 ERA and a 17-to-5 K/BB ratio thus far, there’s no reason for the Braves to think about doing so.&#8221;</p>
                                                                  <a rel='nofollow' class='comment-reply-link' href='http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/?replytocom=195999#respond' onclick='return addComment.moveForm( "comment-195999", "195999", "respond", "17266" )' aria-label='Reply to Bob K.'><i class="fa fa-share"></i> Reply</a>                           </div>
                        </div>
                    </li>
                </ul>
            </div>
         </li>
	</li><!-- #comment-## -->
                </ul>
				 							</div>
           </div>
		        <div class="pix-content-wrap">
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rumblin-stumblin-breakin-even/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.roxwalkoff.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment fullwidth"><textarea id="comment" name="comment"  aria-required="true" placeholder="Write comment" rows="4" cols="39"></textarea></p><!-- #form-section-comment .form-section --><p class="comment-notes">
                            </p>
<p class="comment-form-author"><label class="form-icons">
						<small class="fa fa-ellipsis-v"></small>
						<i class="fa fa-user"></i>
						
					</label>
					<input id="author" name="author" class="nameinput" type="text" value="Name" size="30" tabindex="1"  /><span>(required)</span></p><!-- #form-section-author .form-section -->
<p class="comment-form-email"><label class="form-icons">
						<small class="fa fa-ellipsis-v"></small>
						<i class="fa fa-envelope"></i>
					</label><input id="email" name="email" class="emailinput" type="text"  value="Email" size="30" tabindex="2"/><span>(required)</span></p><!-- #form-section-email .form-section -->
<p class="comment-form-website"><label class="form-icons">
						<small class="fa fa-ellipsis-v"></small>
						<i class="fa fa-phone"></i>
					</label><input id="url" name="url" type="text" class="websiteinput"  value="Website" size="30" tabindex="3" /><span>(required)</span></p><!-- #<span class="hiddenSpellError" pre="">form-section-url</span> .form-section -->
<p class="form-submit"><div  id="g-recaptcha-0" class="g-recaptcha" data-sitekey="6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob" data-theme="light"></div><noscript><div style="width: 302px; height: 462px;"><div style="width: 302px; height: 422px; position: relative;"><div style="width: 302px; height: 422px; position: absolute;"><iframe src="https://www.google.com/recaptcha/api/fallback?k=6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe></div></div><div style="width: 300px; height: 60px; border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px;"><textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px; height: 40px; border: 1px solid #c1c1c1; margin: 10px 25px; padding: 0px; resize: none;" value=""></textarea></div></div><br><br></noscript><input name="submit" type="submit" id="submit-comment" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='17266' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a7c28e7ef3" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="3"/></p>			</form>
			</div><!-- #respond -->
				</div>
     </div>
      		<aside class="sidebar-right col-md-3">
			<div class="widget widget_countdown"></div><div class="widget bwp-rc-widget"><header class="pix-heading-title"><h2 class="pix-section-title heading-color">Recent Comments</h2></header>
		<ul class="bwp-rc-ulist">
<li class="recent-comment">
	<div class="recent-comment-avatar"><img alt='User Avatar' src='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=21&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=42&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-21 photo' height='21' width='21' /></div>
	<h4>Bob K. on <a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/#comment-195999" title="Comment on RUMBLIN,&#039; STUMBLIN,&#039; BREAKIN&#039; EVEN">RUMBLIN,' STUMBLIN,' BREAKIN' EVEN</a></h4>
	<p>"Winkler is finally healthy and been on the Braves 25 man roster long enough that he now fully belongs to the Braves. From MLBTrade Rumors: "Dan Winkler, RHP, Braves: Winkler’s..."</p>
	<div class="meta">Posted Apr 25, 12:48 PM</div>
</li>
<li class="recent-comment">
	<div class="recent-comment-avatar"><img alt='User Avatar' src='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=21&#038;d=identicon&#038;r=pg' srcset='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=42&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-21 photo' height='21' width='21' /></div>
	<h4>sdcarp on <a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/#comment-195998" title="Comment on RUMBLIN,&#039; STUMBLIN,&#039; BREAKIN&#039; EVEN">RUMBLIN,' STUMBLIN,' BREAKIN' EVEN</a></h4>
	<p>"I’m not impressed (never have been) with Pounders. Perhaps he is placeholder until Hoffman is ready then one of the SPers goes into this slot????????"</p>
	<div class="meta">Posted Apr 25, 5:05 AM</div>
</li>
<li class="recent-comment">
	<div class="recent-comment-avatar"><img alt='User Avatar' src='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=21&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=42&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-21 photo' height='21' width='21' /></div>
	<h4>Bob K. on <a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/#comment-195997" title="Comment on RUMBLIN,&#039; STUMBLIN,&#039; BREAKIN&#039; EVEN">RUMBLIN,' STUMBLIN,' BREAKIN' EVEN</a></h4>
	<p>"Oberg optioned to AAA and Zach Jemiola DFAed to make room for Brooks Pounders. https://www.mlbtraderumors.com/2018/04/rockies-select-brooks-pounders-dfa-zach-jemiola.html"</p>
	<div class="meta">Posted Apr 24, 6:39 PM</div>
</li>
<li class="recent-comment">
	<div class="recent-comment-avatar"><img alt='User Avatar' src='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=21&#038;d=identicon&#038;r=pg' srcset='http://2.gravatar.com/avatar/e9d071748368b42e2ddab0a54ec7ad53?s=42&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-21 photo' height='21' width='21' /></div>
	<h4>rockymountainhigh on <a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/#comment-195996" title="Comment on RUMBLIN,&#039; STUMBLIN,&#039; BREAKIN&#039; EVEN">RUMBLIN,' STUMBLIN,' BREAKIN' EVEN</a></h4>
	<p>"I agree, Bob K."</p>
	<div class="meta">Posted Apr 24, 5:55 AM</div>
</li>
<li class="recent-comment">
	<div class="recent-comment-avatar"><img alt='User Avatar' src='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=21&#038;d=identicon&#038;r=pg' srcset='http://0.gravatar.com/avatar/38674cce37515b074d12f7b7b4742a92?s=42&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-21 photo' height='21' width='21' /></div>
	<h4>Bob K. on <a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/#comment-195995" title="Comment on RUMBLIN,&#039; STUMBLIN,&#039; BREAKIN&#039; EVEN">RUMBLIN,' STUMBLIN,' BREAKIN' EVEN</a></h4>
	<p>"I believe it is time to end the Oberg experiment."</p>
	<div class="meta">Posted Apr 24, 4:56 AM</div>
</li>
<li class="recent-comment">
	<div class="recent-comment-avatar"><img alt='User Avatar' src='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=21&#038;d=identicon&#038;r=pg' srcset='http://1.gravatar.com/avatar/420b686ebd077ead86c4e32157fdffdf?s=42&#038;d=identicon&#038;r=pg 2x' class='avatar avatar-21 photo' height='21' width='21' /></div>
	<h4>sdcarp on <a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/#comment-195994" title="Comment on RUMBLIN,&#039; STUMBLIN,&#039; BREAKIN&#039; EVEN">RUMBLIN,' STUMBLIN,' BREAKIN' EVEN</a></h4>
	<p>"Franchy Cordero......what an athlete! The Padres are LOADED with offensive Prospects. Wait until you guys see Luis Urias and Fernando Tatis Jr. Stat of the day: Never in baseball history..."</p>
	<div class="meta">Posted Apr 24, 4:04 AM</div>
</li>
<li class="bwp-rc-ajax-nav">
	<input type="hidden" name="bwp_rc_instance" value="bwp_rc_list" />
	<input type="hidden" name="bwp_rc_paged" value="1" />
	<input type="hidden" name="bwp_rc_paged_limit" value="6" />
 <a title="View older comments" href="#" class="bwp-rc-older-nav">Older »</a></li>
		</ul>
</div><div class="widget widget-recent-blog"><header class="pix-heading-title"><h2 class="pix-section-title heading-color">Popular Post</h2></header>			<article>
			 <figure><a class='pix-colrhvr' href='http://www.roxwalkoff.com/no-relief/' ><img src='http://www.roxwalkoff.com/wp-content/uploads/2016/10/IMG_0127-325x244.jpg' alt=''></a></figure>                <div class="text">
                    <h6>
                        <a href="http://www.roxwalkoff.com/no-relief/"  class='pix-colrhvr'>
                            NO RELIEF                        </a>
                    </h6>
                      		<ul class="post-options">
        	                <li class="featured">
                    
                    Featured		         
                 </li>
		        	                 <li>
                 	                    <time datetime="03-10-16">October 3, 2016</time>
                </li>
						</ul>
					</div>
    		</article>
	    			<article>
			 <figure><a class='pix-colrhvr' href='http://www.roxwalkoff.com/not-spoilers/' ><img src='http://www.roxwalkoff.com/wp-content/uploads/2016/09/IMG_0109-325x244.jpg' alt=''></a></figure>                <div class="text">
                    <h6>
                        <a href="http://www.roxwalkoff.com/not-spoilers/"  class='pix-colrhvr'>
                            NOT SPOILERS                        </a>
                    </h6>
                      		<ul class="post-options">
        	                <li class="featured">
                    
                    Featured		         
                 </li>
		        	                 <li>
                 	                    <time datetime="27-09-16">September 27, 2016</time>
                </li>
						</ul>
					</div>
    		</article>
	    			<article>
			 <figure><a class='pix-colrhvr' href='http://www.roxwalkoff.com/downers-uppers/' ><img src='http://www.roxwalkoff.com/wp-content/uploads/2016/09/IMG_0086-325x244.jpg' alt=''></a></figure>                <div class="text">
                    <h6>
                        <a href="http://www.roxwalkoff.com/downers-uppers/"  class='pix-colrhvr'>
                            DOWNERS + UPPERS                        </a>
                    </h6>
                      		<ul class="post-options">
        	                <li class="featured">
                    
                    Featured		         
                 </li>
		        	                 <li>
                 	                    <time datetime="19-09-16">September 19, 2016</time>
                </li>
						</ul>
					</div>
    		</article>
	    			<article>
			 <figure><a class='pix-colrhvr' href='http://www.roxwalkoff.com/streak-seeking/' ><img src='http://www.roxwalkoff.com/wp-content/uploads/2016/09/IMG_0070-325x244.jpg' alt=''></a></figure>                <div class="text">
                    <h6>
                        <a href="http://www.roxwalkoff.com/streak-seeking/"  class='pix-colrhvr'>
                            STREAK SEEKING                        </a>
                    </h6>
                      		<ul class="post-options">
        	                <li class="featured">
                    
                    Featured		         
                 </li>
		        	                 <li>
                 	                    <time datetime="12-09-16">September 12, 2016</time>
                </li>
						</ul>
					</div>
    		</article>
	    </div><div class="widget facebok_widget">            <style scoped>
				.facebookOuter {background-color: ; width:100%;padding:0;float:left;}
				.facebookInner {float: left; width: 100%;}
				.facebook_module, .fb_iframe_widget > span, .fb_iframe_widget > span > iframe { width: 100% !important;}
				.fb_iframe_widget, .fb-like-box div span iframe { width: 100% !important; float: left;}
			</style>
            <header class="pix-heading-title"><h2 class="pix-section-title heading-color">Follow Us </h2></header>		
        
        	<div id="fb-root"></div>
			<script>(function(d, s, id) {
              var js, fjs = d.getElementsByTagName(s)[0];
              if (d.getElementById(id)) return;
              js = d.createElement(s); js.id = id;
               js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
              fjs.parentNode.insertBefore(js, fjs);
            }(document, 'script', 'facebook-jssdk'));</script>
			
            <div style="background:;" class="fb-like-box"  data-href="https://www.facebook.com/roxwalkoff" data-width=" "  data-height=" "  data-hide-cover="false"  data-show-facepile="true"  data-show-posts="true"> </div></div>        </aside>
 	                </div>
            </div> 
                             </div>
    	<!-- Inner Main -->
    </div>
    <div class="footer-widget">
            	<div class="container">
        	            <div class="footer-icons">
                <div class="followus">                    	<a title="" href="http://facebook.com/roxwalkoff" data-original-title="Facebook" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-facebook-square icon"></i></a>
					                    	<a title="" href="https://twitter.com/roxWalkOff" data-original-title="Twitter" data-placement="top"  class="colrhover"  target="_blank">
						 
                    <i class="fa fa-twitter-square icon"></i></a>
					</div>            </div>
        </div>
                <!-- Container Start -->
                <div class="container">
            <!-- Footer Widgets Start -->
            <div class="widget widget_nav_menu"><header class="px-heading-title"><h2 class="px-section-title">Quick Links</h2></header><div class="menu-roxmenu-container"><ul id="menu-roxmenu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-465"><a href="http://www.roxwalkoff.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15745"><a href="http://www.roxwalkoff.com/roxnews/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15916"><a href="http://www.roxwalkoff.com/game-day/">GAME DAY</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15846"><a href="http://www.roxwalkoff.com/dr-cs-musings/">Dr. C’s Musings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15917"><a href="http://www.roxwalkoff.com/soundoff/">SOUND OFF</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15728"><a href="http://www.roxwalkoff.com/category/hotplate/">Hot Stove</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15729"><a href="http://www.roxwalkoff.com/edtheump/">Edtheump</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15730"><a href="http://www.roxwalkoff.com/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15731"><a href="http://www.roxwalkoff.com/contact/">Contact</a></li>
</ul></div></div>		<div class="widget widget_recent_entries">		<header class="px-heading-title"><h2 class="px-section-title">Latest Blog</h2></header>		<ul>
											<li>
					<a href="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/">RUMBLIN,&#8217; STUMBLIN,&#8217; BREAKIN&#8217; EVEN</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/nolan-freed-from-suspension/">Nolan Freed From Suspension</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/ready-to-rumble/">READY TO RUMBLE?</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/rox-convert-me-into-debbie-downer/">Rox Convert Me Into Debbie Downer</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/meh-2/">Meh.</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/rox-end-road-trip-at-4-3/">Rox End Road Trip at 4-3</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/contention-pretension/">Contention Pretension</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/spring-training-notes/">Spring Training Notes</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/rockies-prepare-for-2018-run/">Rockies Prepare for 2018 Run</a>
									</li>
											<li>
					<a href="http://www.roxwalkoff.com/2018-hot-stove-phase-ii-winter-meetings-to-pitchers-catchers-report/">2018 Hot Stove Phase II &#8211; Winter Meetings to Pitchers/Catchers Report</a>
									</li>
					</ul>
		</div><div class="widget widget_categories"><header class="px-heading-title"><h2 class="px-section-title">Categories</h2></header>		<ul>
	<li class="cat-item cat-item-614"><a href="http://www.roxwalkoff.com/category/10-season-reviews/" >10% Season Reviews</a> (8)
</li>
	<li class="cat-item cat-item-12"><a href="http://www.roxwalkoff.com/category/aroundtheleague/" title="News on other players Around the League...">Around the League</a> (42)
</li>
	<li class="cat-item cat-item-616"><a href="http://www.roxwalkoff.com/category/dr-c-musings/" title="An area for Dr. C&#039;s Awesome Musings!">Dr. C&#039;s Musings</a> (54)
</li>
	<li class="cat-item cat-item-163"><a href="http://www.roxwalkoff.com/category/gameday/" title="Game Day Posts">Game Day</a> (723)
</li>
	<li class="cat-item cat-item-613"><a href="http://www.roxwalkoff.com/category/give-your-feedback/" >Give Your Feedback</a> (3)
</li>
	<li class="cat-item cat-item-14"><a href="http://www.roxwalkoff.com/category/hotplate/" title="Trade rumors and realities">Hot Stove</a> (66)
</li>
	<li class="cat-item cat-item-162"><a href="http://www.roxwalkoff.com/category/keydates/" title="Important Dates for the Rox">Key Dates</a> (6)
</li>
	<li class="cat-item cat-item-694"><a href="http://www.roxwalkoff.com/category/new-post/" title="all new post">New Post</a> (217)
</li>
	<li class="cat-item cat-item-3"><a href="http://www.roxwalkoff.com/category/news/" title="Rox news from around the interweb.">News</a> (777)
</li>
	<li class="cat-item cat-item-421"><a href="http://www.roxwalkoff.com/category/post-game/" >Post Game</a> (385)
</li>
	<li class="cat-item cat-item-388"><a href="http://www.roxwalkoff.com/category/quick-news/" >Quick News</a> (54)
</li>
	<li class="cat-item cat-item-243"><a href="http://www.roxwalkoff.com/category/farm/" title="Coverage of Rockies Farm Teams">Rox Farm Report</a> (12)
</li>
	<li class="cat-item cat-item-13"><a href="http://www.roxwalkoff.com/category/quick-news/spring-training/soundoff/" title="Your thoughts on the Rox">Sound Off</a> (281)
</li>
	<li class="cat-item cat-item-412"><a href="http://www.roxwalkoff.com/category/quick-news/spring-training/" >Spring Training</a> (37)
</li>
	<li class="cat-item cat-item-615"><a href="http://www.roxwalkoff.com/category/statistics/" >Statistics</a> (9)
</li>
	<li class="cat-item cat-item-442"><a href="http://www.roxwalkoff.com/category/walk-off/" >WALK OFF</a> (32)
</li>
	<li class="cat-item cat-item-441"><a href="http://www.roxwalkoff.com/category/week-in-review/" >Week in Review</a> (10)
</li>
		</ul>
</div><div class="widget widget_wp_sidebarlogin"><header class="px-heading-title"><h2 class="px-section-title">Login</h2></header>
		<form name="loginform" id="loginform" action="http://www.roxwalkoff.com/wp-login.php?itsec-hb-token=roxwalkoff-admin" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Login &rarr;" />
				<input type="hidden" name="redirect_to" value="http://www.roxwalkoff.com/rumblin-stumblin-breakin-even/" />
			</p>
			
		</form><ul class="pagenav sidebar_login_links"><li class="register-link"><a href="http://www.roxwalkoff.com/wp-login.php?action=register&#038;itsec-hb-token=wp-register-php">Register</a></li><li class="lost_password-link"><a href="http://www.roxwalkoff.com/wp-login.php?itsec-hb-token=roxwalkoff-admin&#038;action=lostpassword">Lost Password</a></li></ul></div>            <!-- Footer Widgets End -->
        </div>
                <!-- Container End -->
    	<footer id="footer">
            <div class="container">
                <p class="coptyright">
                    ©2016 Rox Walk Off: Colorado Rockies News and Fan Gathering Place All Rights Reserved.                </p>
                <!--<a href="" class="btn btngotop"><i class="fa fa-arrow-circle-o-up"></i></a>-->
            </div>
        </footer>
    </div>
</div>
<!-- Wrapper End -->

<!-- BEGIN recaptcha, injected by plugin wp-recaptcha-integration  -->
<script type="text/javascript">
				function get_form_submits(el){
					var form,current=el,ui,type,slice = Array.prototype.slice,self=this;
					this.submits=[];
					this.form=false;

					this.setEnabled=function(e){
						for ( var s=0;s<self.submits.length;s++ ) {
							if (e) self.submits[s].removeAttribute('disabled');
							else  self.submits[s].setAttribute('disabled','disabled');
						}
						return this;
					};
					while ( current && current.nodeName != 'BODY' && current.nodeName != 'FORM' ) {
						current = current.parentNode;
					}
					if ( !current || current.nodeName != 'FORM' )
						return false;
					this.form=current;
					ui=slice.call(this.form.getElementsByTagName('input')).concat(slice.call(this.form.getElementsByTagName('button')));
					for (var i = 0; i < ui.length; i++) if ( (type=ui[i].getAttribute('TYPE')) && type=='submit' ) this.submits.push(ui[i]);
					return this;
				}
				</script><script type="text/javascript">
		var recaptcha_widgets={};
		function wp_recaptchaLoadCallback(){
			try {
				grecaptcha;
			} catch(err){
				return;
			}
			var e = document.querySelectorAll ? document.querySelectorAll('.g-recaptcha:not(.wpcf7-form-control)') : document.getElementsByClassName('g-recaptcha'),
				form_submits;

			for (var i=0;i<e.length;i++) {
				(function(el){
					var form_submits = get_form_submits(el).setEnabled(false), wid;
					// check if captcha element is unrendered
					if ( ! el.childNodes.length) {
						wid = grecaptcha.render(el,{
							'sitekey':'6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob',
							'theme':el.getAttribute('data-theme') || 'light'
							,
							'callback' : function(r){ get_form_submits(el).setEnabled(true); /* enable submit buttons */ }
						});
						el.setAttribute('data-widget-id',wid);
					} else {
						wid = el.getAttribute('data-widget-id');
						grecaptcha.reset(wid);
					}
				})(e[i]);
			}
		}

		// if jquery present re-render jquery/ajax loaded captcha elements
		if ( typeof jQuery !== 'undefined' )
			jQuery(document).ajaxComplete( function(evt,xhr,set){
				if( xhr.responseText && xhr.responseText.indexOf('6LdeWxUUAAAAAMT0Lh1pEYaagi9aEZjdQ6Om5Rob') !== -1)
					wp_recaptchaLoadCallback();
			} );

		</script><script src="https://www.google.com/recaptcha/api.js?onload=wp_recaptchaLoadCallback&#038;render=explicit" async defer></script>
<!-- END recaptcha -->
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.roxwalkoff.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.2'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/blankshield/blankshield.min.js?ver=4080'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/block-tabnapping.js?ver=4080'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/bootstrap.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/modernizr.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-content/themes/kingclub-theme/scripts/frontend/jquery.prettyphoto.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.roxwalkoff.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://s7.addthis.com/js/250/addthis_widget.js?ver=4.9.5#pubid=xa-4e4412d954dccc64'></script>
<script async="async" type='text/javascript' src='http://www.roxwalkoff.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.3'></script>
</body>
</html>
